Visual Studio - References to Bolt assets break after Bolt Compile Assembly

Every time I compile bolt assembly in the Unity Editor, the references to all my Bolt assets break in Visual Studio break and I get the "missing directive or assembly reference" in visual studio. The only way to resolve this that I have found is to close and reopen visual studio, which is causing me tremendous slowdown in productivity. I have tried refreshing the projects and reordering them, to no avail. Any idea why this is happening and how to resolve it?

Visual Studio 2015
Unity 5.4.1
Bolt 4.3.17


  • Anyone? Is this a known issue or am experiencing something out of the ordinary?
  • I've never experienced this. Have you tried reinstalling Bolt?
  • EnterTalement
    edited October 2020
    Sorry to hijack and revive this thread, but we have a similar problem and really struggle with it.
    Every time we compile the bolt assembly with actual changes (like asset changes, new prefabs or build setting scene changes), all our prefabs and scriptable objects in Unity lose their references to prefabs with bolt entity components.
    For example: Scriptable object A has a reference to prefab B, and prefab B has a bolt entity component. If we compile the bolt assembly, scriptable object A loses its reference to prefab B.
    This behavior is very annoying, as we have to manually reassign all the references to prefabs with bolt entities over and over.
    We use the new version of bolt from the 10th August, but we had the same issue with previous versions.

    So, is this problem known to others and if so, do you have a workaround / solution for it?
  • Hello @EnterTalement ,

    That is not a known issue, and it seems really strange to happen.
    Are you able to send us via email a reproduction project so we can take a look?

    Also, what is your current setup? Unity, Bolt, OS.

    Ramon Melo
    Photon Bolt Team
  • EnterTalement
    edited October 2020
    Hey @ramonmelo ,
    thanks for your quick response.
    Our setup is Unity 2019.2.21f1, Bolt version 1.2.13 (according to the readme) and windows 10 as the developer OS.

    We have no seperate reproduction project right now, just our game project.
    But it is good to know, that the problem is not a known issue.

    We will try to update Unity to a newer version first, and create a reproduction project, if the issue still exists.
  • Ok, we have done sereval tests now, and it seems like updating our project (unity, bolt, etc.) has done the deal. We really don't know what caused the bug, but we cannot replicate it anymore.

    So consider this thread closed, we will create a new post, when the bugs appears again.
    Many thanks for your help nonetheless :)