Random Voice Drop for the day


Yesterday I experienced a very strange phenomenon regarding PhotonVoice with a Unity Build, using PhotonUnityNetworking and PhotonVoice for Oculus quest and Oculus Rift.

For this project we have 4 VR sets, 2 in Asia and 2 in Europe. Until now we have been able to communicate seamlessly unless there is a congested network, where some crackling appears for the voice of the user with the congested network.

Last Monday (27.07.2020) we run a test using one build and everything worked fine. Yesterday (30.07.2020) we used the same .exe to run another test and the voice suddenly did not work, both sets in Asia could speak and hear each other. Both sets in Europe could hear the VR Sets in Asia, but they could not hear each other and also, the sets in Asia could not hear the sets in Europe.

We tried another demo built on the spot and it did also not work and the 2 VR sets in Europe were connected to 3 different PCs to discard output device malfunctions.
We could not find anything on Unity's log files either.
After considering and discarding Driver Updates, Windows Updates, Oculus updates I went home for the day.

Today both demos work as expected.

Could it be that the european server dropped around noon (GMT +01:00) time?

I am just trying to understand what happened.
Thanks and best regards


  • JohnTube
    JohnTube ✭✭✭✭✭
    edited August 2020
    Hi @Aitor,

    Maybe clients were simply connected to a different region each or joined to a different room each?
    Maybe AppVersion or AppId mismatch?

    Could you make sure it's not a matchmaking issue?
  • Hi @JohnTube

    Thanks for your reply.

    It is the studio in Asia creating the Unity Build and I know the region set in photonserversettings is Asia.
    We have never had issues while connecting from different regions. As mentioned above 2 of the sets connect from EU and 2 from Asia. I guess this just translates in higher latency for the ones is EU.

    The thing that baffles me is that the same build, on different days, had 2 different outcomes.
    First time voice was working just fine. Second time it did not work.
    We were running the executable, not from Unity Editor, both times and our app has no runtime way of changing the region, App version or App ID.

    I have to say that it has not occurred again since then.

    Thanks for your support.