Can't connect

edited February 2019 in Photon Voice

I'm trying to get Photon Voice 2 to work in my project.

I'm Using Unity 2017.4.1f1 and Photon Voice 2.3 .

I tried to import Photon Voice 2 directly in my existing project, but had many errors so I'm starting from a new/clean project as you suggested in other posts.

In new project only thing I've done is importing Photon Voice 2 and setting the AppID for Voice.

This is a tipical log running the DemoVoice scene.


  • JohnTube
    JohnTube mod
    edited February 2019
    Hi @amg,

    Thank you for choosing Photon!

    I'm Using Unity 2014.4.1f1

    You mean Unity 2017 and not Unity 2014 :)

    I guess you are using DemoVoice scene from DemoVoiceUI?

    It looks like the AppId was not properly set but maybe that's not the cause.

    Could you take a screenshot of the AppSettings? Do you use PUN2 Settings?

    Also, make sure is reachable from your network.
    See "Analyzing Disconnects (Timeout Disconnect)" and "TCP and UDP ports".
  • It seems I can't reach I tried ping, an online telnet service and an online udp ping service.

    How could I check reachability of your server?

    If I also set the App Id Realtime then it appears correctly in the log. Yes I use PUN Settings

  • Hi @amg,

    You need to try in a different network that can reach our nameserver.
  • I tried on different hardware that has some different network configuration (don't know precisely what differs) and it worked instantly.

    Thanks so much for the fast responses!