"Game does not exist" (Android Game)

KOFKOF
KOFKOF

Hi,

Im making an android game with the Photon 2 Free version. Im having some issues with the Joining Room part. With my first device (phone/pc) i can make/create a room but with my second device it just says "Game does not exist". I just made a new room with the code "376060".

In the second device i have an input where you insert the room code (variable name: roomCode):

And then the output message i get:


Server Settings:


If you think this post need more information i will gladly add it.

Thanks in advance.



UPDATE #1:

I have tried with JoinOrCreateRoom and it worked so it seems JoinRoom(code) is the only one that doesnt work. Unfortunate i can use JoinOrCreateRoom on my project so i still need help here.

Comments

  • Tobias
    Tobias admin
    edited September 2022

    JoinOrCreate room may create a room of the name. This helps if players want to get into the same room at about the same time. One creates it but everyone else can also join.

    JoinRoom() never creates a room, so someone has to first create it (and it needs to be confirmed by the GS as existing / created before it can be joined).

    Might be a timing issue.