[Exception] InvalidOperationException: Not Found: [Tick:280]

JoshDBB
JoshDBB
edited December 2021 in Fusion

I am just getting started with fusion and I am hitting an error. I have started with the 'Hello Fusion' sample project (it is the latest version that uses fusion 0.13). All I have done to it is duplicate the physics boxes a load and spread them out (there are now 450 of them). I have one player start as the host, this works fine. When the second player tried to join as a client it sits there for a while then I get a load of errors on the client and don't see the scene update.

Unity version: 2020.3.12

I have also tried updating fusion to the latest build: 0.13.0.374


This is the error:

[Exception] InvalidOperationException: Not Found: [Tick:280]
Simulation.FindSnapshot() at Fusion/Fusion.Runtime/Simulation/Simulation.cs:1598

Simulation+StateReplicatorDeltaSnapshot.RecvPacket() at Fusion/Fusion.Runtime/Simulation/Simulation.StateReplicatorDeltaSnapshot.cs:163

Simulation+Client.RecvPacket() at Fusion/Fusion.Runtime/Simulation/Simulation.Client.cs:246

Fusion.Simulation.Fusion.Sockets.INetPeerGroupCallbacks.OnNotifyData() at Fusion/Fusion.Runtime/Simulation/Simulation.INetPeerGroupCallbacks.cs:283

NetPeerGroup.HandlePacketNotifyData() at Fusion/Fusion.Sockets/NetPeerGroup.cs:768

NetPeerGroup.HandlePacket() at Fusion/Fusion.Sockets/NetPeerGroup.cs:616

NetPeerGroup.Receive() at Fusion/Fusion.Sockets/NetPeerGroup.cs:563

NetPeerGroup.Update() at Fusion/Fusion.Sockets/NetPeerGroup.cs:142

Simulation.NetworkRecv() at Fusion/Fusion.Runtime/Simulation/Simulation.INetPeerGroupCallbacks.cs:101

Simulation.Update() at Fusion/Fusion.Runtime/Simulation/Simulation.cs:883

NetworkRunner.UpdateInternal() at Fusion/Fusion.Runtime/Runner/NetworkRunner.cs:1128

NetworkRunnerUpdater.InvokeUpdate() at Fusion/Fusion.Runtime/Runner/NetworkRunnerUpdater.cs:75


Any help would be much appreciated.


edit-

It seems that this issue doesn't occur when the client is running on OSX, I only see the issue when the client is running on Windows (I should mention that the Windows computers and the OSX computers are in different locations with different internet connections).

I think it may be in some way caused by the length of time that it takes to join the game (it may just be that OSX joins faster than windows, hard to say as testing remotely).

Answers

  • ramonmelo
    ramonmelo mod
    edited January 7

    Hi @JoshDBB ,


    You are using an older version of the Fusion SDK, can you try to update to the latest version?


    --

    Ramon Melo

    Photon Fusion Team