System.Exception: No valid LAN EndPoint resolved.

I'm using Photon Bolt on the Nintendo Swtich and recently since I upgraded to the new version of Photon Bolt 1.3 I've had the following error when the server and client connect in my 2 player game, any ideas why? The main error seems to be System.Exception: No valid LAN EndPoint resolved. But below is the log of the full output.


[Switch] NetworkConnected Accepted (No events)

OnGetMatch


Bolt Free Debug v1.3.1 starting with a simulation rate of 60 on platform Switch


[STUN] Reset configs


Reusing UdpKit Task with ID: 4


Creating Global Behaviour: 'Photon.Bolt.Utils.BoltConsole'


Creating Global Behaviour: 'Photon.Bolt.Utils.BoltPhysicsDebug'


Creating Global Behaviour: 'Photon.Bolt.Internal.BoltPoll'


Creating Global Behaviour: 'Photon.Bolt.Internal.BoltSend'


Creating Global Behaviour: 'Photon.Bolt.SceneManagement.BoltSceneLoader'


Creating Global Behaviour: 'Photon.Bolt.PhotonCloudGlobalBehavior+PhotonBoltBehavior'


Creating Global Behaviour: 'Photon.Bolt.PhotonCloudGlobalBehavior'


Registered token class Photon.Bolt.PhotonRoomProperties as id 1


Registered token class Photon.Bolt.Tokens.BoltDisconnectToken as id 2


BoltProtocolTokenRegistry not found, system disabled.


Binding physical socket using platform 'UdpKit.Platform.PhotonPlatform' with IP [EndPoint IPv4 0.0.0.0:0]


[Switch] NetworkConnected Accepted (No events)

Physical socket bound to 0.0.0.0:0


System.Exception: No valid LAN EndPoint resolved.

 at UdpKit.UdpSocket.OnEventStart (UdpKit.UdpEvent ev) [0x00000] in <00000000000000000000000000000000>:0 

 at UdpKit.UdpSocket.ProcessStartEvent () [0x00000] in <00000000000000000000000000000000>:0 

 at UdpKit.UdpSocket.NetworkLoop () [0x00000] in <00000000000000000000000000000000>:0 

 at System.Action.Invoke () [0x00000] in <00000000000000000000000000000000>:0 

 at UdpKit.Async.Task.Runner () [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ThreadStart.Invoke () [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ContextCallback.Invoke (System.Object state) [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ThreadHelper.ThreadStart () [0x00000] in <00000000000000000000000000000000>:0 

 at System.Threading.ThreadStart.Invoke () [0x00000] in <00000000000000000000000000000000>:0 


BoltStartFailed

Best Answer

Answers

This discussion has been closed.