Pun2 2.29 causes script errors when using 'simple' scripts

I just tried to update to the latest version of PUN2, and it caused me errors after the update.
Has simple been discontinued as of the latest update? Its not in the imported files..

Comments

  • No option to edit, I wanted to note that I am using the current version of Unity 2020.2.7f1, and when I say imported files, I am referring to when I import PUN2 from the asset store, into unity; There is no longer a folder for \PhotonUtilities\ nor is there a folder named \simple\

    My game runs best when utilizing the simple assets, To remove them would create much more work; I hope I am just overlooking something.
  • Hi @sdsdink,

    Thank you for choosing Photon!

    Simple is no longer included in PUN2 package.
    You need to download it and import it separately on top of PUN2.
    Read more here.
  • Perfect, Thank you John! This was very helpful!
  • So, after updating, I am getting errors when transferring ownership.

    This error didnt occur prior to the update.. It seems to be something to do with the netmaster, and something that must have been changed in the update:

    Failed to find a PhotonView with ID=0 for incoming OwnershipTransfer event (newOwnerActorNumber=1), sender=1
    UnityEngine.Debug:LogErrorFormat (string,object[])
    Photon.Pun.PhotonNetwork:OnEvent (ExitGames.Client.Photon.EventData) (at Assets/Photon/PhotonUnityNetworking/Code/PhotonNetworkPart.cs:2398)
    Photon.Realtime.LoadBalancingClient:OnEvent (ExitGames.Client.Photon.EventData) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:3289)
    ExitGames.Client.Photon.PeerBase:DeserializeMessageAndCallback (ExitGames.Client.Photon.StreamBuffer) (at D:/Dev/Work/photon-dotnet-sdk/PhotonDotNet/PeerBase.cs:891)
    ExitGames.Client.Photon.EnetPeer:DispatchIncomingCommands () (at D:/Dev/Work/photon-dotnet-sdk/PhotonDotNet/EnetPeer.cs:558)
    ExitGames.Client.Photon.PhotonPeer:DispatchIncomingCommands () (at D:/Dev/Work/photon-dotnet-sdk/PhotonDotNet/PhotonPeer.cs:1837)
    Photon.Pun.Simple.NetMaster:FixedUpdate () (at Assets/Photon/Simple/Core/NetMaster/NetMaster.cs:163)

    Whats going on?
  • this is for @emotitron

  • Just touching base on this, But I reverted back to my previous version of PUN, and everything works as intended.
  • Just curious if this was fixed? I like to try and stay caught up on updates. Regards.

  • From how old a version of Pun2 did you upgrade? Simple was removed from the Asset Store Pun2 and is now provided as a separate downloadable. So you might need to grab that version of Simple?

    https://github.com/emotitron/Simple_Addon_for_Pun2/releases
  • sdsdinksdsdink
    edited April 6

    I'm not at my pc right now, but I was current, so I had the most recent version available prior to the new update.

    I downloaded that simple from the git, and added it to the new pun version. This was all done prior to posting on March 31 and asking for help.

    If there is any way I can help let me know.

  • TobiasTobias admin
    In doubt, just get the 2.28 release of Simple once more and import it.
    As far as we can see, it's compatible.
    If you notice errors after the update, it helps to send the editor log (as txt).
  • We did just catch a bug that this may be related to, so I would give it a shot with the next Pun2 update. Sorry about the issues you are having @sdsdink .
Sign In or Register to comment.