PUN 2 + self hosted server on google cloud

I have working game using Photon Cloud as server side and PUN 2 plugin for Unity3d.
Now I decided to move to my own self-hosted server. I run default server on dedicated machine: Start as application "LoadBalancing (MyCloud)" the ip set to public, all firewall ports are opens 5055/5056. but i'm still not able to connect to the server. Could you help me please, what I am doing wrong?
May be you just point me on documentation - how run self-hosted server on google cloud?

Thanks!

Comments

  • hi, @leashZh

    you have to check logs in deploy/bin_Win64/log folder. I assume that PUN2 uses protocol 1.8 that is not supported by currently released sdk. you have to change your connection to use protocol 1.6

    please ask JohnTube if you need a hint how to use protocol 1.6 in PUN 2

    best,
    ilya
  • leashZhleashZh
    edited January 15
    Thanks for your replying @chvetsov . @JohnTube Could you please help, and check what I am doing wrong? here is my setup and logs:

    https://ibb.co/Dt7gFR4
    https://ibb.co/dcb92Nr
    https://ibb.co/N7spgcy
    https://ibb.co/HTNK3FL
    https://ibb.co/6gtSTmm
    https://ibb.co/zfHxyFF
    https://ibb.co/D8Sm8X1

    BTW, I can run the server on my pc without any issue.

  • up
  • hi, @leashZh
    what error do you get back from the server? it should be logged by PUN

    best,
    ilya
  • leashZhleashZh
    edited January 16
    hi, @chvetsov
    here is the error that show on unity:
    Resending: CMD(2 ch#/sq#/usq#: 255/1/0 r#/st/tt:1/22/10022). times out after: 220 sent: 22 now: 287 rtt/var: 200/5 last recv: 637266
    UnityEngine.Debug:Log(Object)
    Photon.Realtime.LoadBalancingClient:DebugReturn(DebugLevel, String) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:2130)
    ExitGames.Client.Photon.EnetPeer:SendOutgoingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/EnetPeer.cs:808)
    ExitGames.Client.Photon.PhotonPeer:SendOutgoingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/PhotonPeer.cs:1555)
    Photon.Pun.PhotonHandler:LateUpdate() (at Assets/Photon/PhotonUnityNetworking/Code/PhotonHandler.cs:170)

    [8.970] SupportLogger Info: AppID: "" AppVersion: "_2.16" UserId: f2fe4aa1-1ff0-44ef-90d6-25ff6cffc2ae PeerID: 65535 NameServer: ns.exitgames.com Server: 35.192.34.152:5055 IP: 35.192.34.152:5055 Region:

    [8.972] SupportLogger Rtt(variance): 200(5). Since receive: 69014ms. Longest send: 0ms. Stats elapsed: 0sec.
    Longest delta between Send: 0ms Dispatch: 0ms. Longest callback OnEv: 0=0ms OnResp: 0=0ms. Calls of Send: 0 Dispatch: 0. Ping min/max: 0/0

    thanks,
  • @leashZh it looks like you can not connect to your server.

    Please start with getting to work a local server client. if it works then do next steps. According to what I saw from logs server is up and running. so it listens on IP addresses and ports where you are trying to connect.

    I would say that there is some issue with firewall configuration


    best,
    ilya
Sign In or Register to comment.