Calibration of VAD not stopping

Hello,
I'm trying to set up Recorder VAD. It seems that recorder initialization is successful but when I start calibration process it does not seem to end. I tried starting it both via script and with the button in the inspector.
I tried setting Log Level to ALL and press calibrate button in inspector but I did not get any messages. After pressing the button inspector UI changes from "Calibration time(ms) 200" to "calibrating 200 ms" and the number is not going down.

Anyone has any idea what might be happening here?

I am using Photon Voice 2.8 and Unity 2019.2.0f1.

Comments

  • Hi @Gom,

    Thank you for choosing Photon!

    Does this happen all the time?
    Does this happen with demo scenes?
    How can we reproduce?

    Does Recorder.VoiceDetectorCalibrating return true all the time?
  • Yes, it was returning true all the time. Now playing around in the demo scene I noticed that calibration does not end if Transmit Enabled set to false.
    If Transmit Enabled is set to false I can still see the Calibrate button but after pressing it calibration does not end and VoiceDetectorCalibrating always returns true.
    Calibrate button only disappears if IsRecording is set to false.

    I set both IsRecording and Transmit Enabled to true and it seems to be working now.

    Now I am confused what exactly Transmit Enabled does. As I understood VAD was supposed to toggle it?

    Thanks
  • The only place I found describing this is here: https://doc.photonengine.com/en-us/voice/v2/getting-started/recorder. But I can not figure out what all of the booleans do there. Is there somewhere a more detailed description of this component?
  • Hi @Gom,

    We have reproduced this.
    We will fix this and let you know.
    We will either share quick fix here or release an update.
Sign In or Register to comment.