Loadbalancing sample JoinGame failed (fixed)

edited November 2018 in Photon Server
I've setup an Amazon ec2
and am running the PhotonControl.exe on it. I've opened all the ports listed in the docs (even though it says it does it automatically?)
but I can't seem to connect. I've tried both as an application and as a service, using the public IP.
JoinGame failed: ReturnCode: 32758 (Game does not exists).

If I run PhotonControl and the TestClient on my local machine using the local IP it works fine. On the server both local and public IPs are not connecting using the TestClient, nor my local machines application.

Is this a port problem?


  • edited November 2018
    I tried changing all the IPs in the server config to match the server public IP and got this in the logs
    3100: 07:45:08.596 - CService::OnException() - Exception: CSocket::Bind() *.*.*.*:843 - The requested address is not valid in its context.
  • =3 figured it out.
    Just setting up the security groups within the instance is not enough. You have to go back to the dashboard, select the instance, and specify use of the security group. Partly because I created a new one called Photon instead of adding to the "default" group.
Sign In or Register to comment.