PUN replacing dots with commas when passing a string trough OnSerializeView (LL2CPP BUILD)

Im really lost on this one, This didn't start to happen until recently, out of the blue. It messed up my whole project and its unplayable. I use strings with all the info needed and then decompose them in the OnSerializeView, in order to pass transform position, rotation and other properties.

Recenlt yand out of the blue, it started replacing dots on my string by commas on transfer, or directly changing the values oddly. I can't understand this since I don't pass any float, vector or anything. ITs all strings and it all worked perfectly during a long time. I don't know what to do any more, since the string I pass on "stream.iswriting" is alright, but the one that "stream.isreading" returns is messed up, as I said, with many dots replaced by commas, so there goes all my vector, float and double parsing. I have Unity 2018 and the latest version of Unity Classic.

I am completely lost on this one.

EDIT. Just saw that with Mono, those values don't get screwed. Is there any way to be able to use photon with LL2Cpp so I can have the enhanced anticheat and antipiracy?


  • Hi @Cardboard_Claw_Games,

    I can't reproduce this. I tried both Scripting Runtime Versions in Unity 2018.1 with Scripting Backend set to IL2CPP. Both ran fine in my tests: I didn't have any problem with replaced dots.

    I'm asking you to check this behaviour in a fresh Unity project to see if it happens there, too. If so, I'm furthermore asking you to create a repro case for me so that I can take a look at it.
Sign In or Register to comment.