Help with Netsync Demo

edited August 2010 in Photon Server
Hi. Im pretty sure ive followed the instructions in the readme.txt file exactly, however im getting the following error in the logs

3368: 14:10:50.220 - CService::OnException() - Exception: CManagedHost::CreateApplicationDomain() - Failed to create new application domain for : "NetSync" - The domain manager specified by the host could not be instantiated.

Im running SDK 2.0.5 (though Photon Control dialog shows version number as 2.0.4), Win32_xp.

Any suggestions?

Thanks
Vinnie

Comments

  • I retested the complete steps and it worked here, so there is no obvious flaw.
    I can't reproduce the error. When I remove the Netsync files from the deploy-folder, I get a different error, so that's not it.

    Do you have DotNet 3.5 (or up) and the latest service packs installed? You use the binaries and config from \deploy\bin_Win32_xp?
  • Hi Tobias. Thanks for your response.
    Yes I do have DotNet 3.5 (plus SP 1) installed. Im able run the simple cube/checker board demo successfully against the Lite server.
    When you say "the binaries and config from \deploy\bin_Win32_xp" can you be more specific please?

    Also, is the fact that the Photon Control dialog is showing version number as 2.0.4 (despite installing the latest SDK) an issue?

    thanks.
  • When you say "the binaries and config from \deploy\bin_Win32_xp" can you be more specific please?
    I wanted to be sure that you use the content of bin_Win32_xp, as it's a special build for the "older" OS. You answered this when you said it's running Lite without issues.

    I still can't explain whats is causing the problem with the domain manager. Have you tried to run only the NetSync project but nothing else?
    If that does not, I would like to send you a new server build which possibly logs the exact reason of this, if you agree.
    Also, is the fact that the Photon Control dialog is showing version number as 2.0.4 (despite installing the latest SDK) an issue?
    No, the Photon Control just has it's own versioning. Sometimes we don't change it between releases and sometimes it gets bigger updates. No worries.
  • Thanks for clarifying. Ive tried running only the NetSync app, same results. Im keen to resolve, so yeah very happy to try a new server build..

    cheers.
  • Sent you the download as private message.
Sign In or Register to comment.