Adding remote slave to Photon Load Balancing

Hello, we run our own Photon Load Balancing server for use with PUN. I'm attempting to get this ready to scale so I have the Master and Client1 on one machine and I wish to put Client2 on another machine.

Right now the Master and Client1 are connecting just fine and work correctly. However Client2 cannot connect to the Master. I have disabled the firewall on both machines and allowed all traffic and the problem still occurs so this makes me think it is a problem with my config setup. Can I double check some of my choices please?

The log I see on Client2 is

2018-10-02 14:30:51,091 [20] INFO Photon.LoadBalancing.GameServer.GameApplication [(null)] - Connecting to master at [CORRECT_PUBLIC_IP]:4520, serverId=7cbff663-5778-4c9a-8d28-358b105eb266
2018-10-02 14:31:12,103 [14] WARN Photon.LoadBalancing.GameServer.GameApplication [(null)] - Master connection failed with err 121: The semaphore timeout period has expired., serverId=7cbff663-5778-4c9a-8d28-358b105eb266

The PhotonServer.config file has these lines (I've removed the opening brackets so the HTML doesn't get stripped),
!-- DON'T EDIT THIS. TCP listener for GameServers on Master application -->

so I have left the Photon.LoadBalancing.dll.config lines
!-- Gameserver-to-Master connections. -->
setting name="OutgoingMasterServerPeerPort" serializeAs="String">

For the rest of the fields in Photon.LoadBalancing.dll.config in Photon.LoadBalancing.GameServer.GameServerSettings I make sure the ports for GamingTcpPort, GamingUdpPort, and GamingWebSocketPort are all in the master server's PhotonServer.config in the relevant Listeners blocks and these ports are in the Master's socket-policy.xml.

At this point I can't see anything else I need to configure. Can anyone shed some light on what I may be missing? Thanks for all your help, and sorry if this is a bit dense!



Sign In or Register to comment.