BoltNetwork.Connect() is inaccessible due to its protection level

I'm basically just following tutorials and running into this error at the moment, which is frustrating. The specific thing that is inaccessible is the BoltNetwork.Connect() function. Any idea what the issue could be?


  • Same problem for me.
    `BoltNetwork.Connect(UdpKit.UdpEndPoint)' is inaccessible due to its protection level

    I also get other inaccessibility errors when I try to build for android.
  • We are updating the docs to make them compatible with Bolt free. Please check again on Monday.
  • stanchionstanchion mod
    edited September 2018
    @Interlude @andyasj We've updated the getting started docs. There are still a few other docs with issues, they'll be resolved soon.
  • Thanks!
  • @stanchion
    I downloaded Bolt free today and getting the same errors after using the wizard within the editor, so can't do anything - platform android

    Assets/bolt/scripts/BoltDebugStart.cs(73,19): error CS0122: `BoltNetwork.Connect(UdpKit.UdpEndPoint)' is inaccessible due to its protection level

    Assets/bolt/scripts/BoltLauncher.cs(194,20): error CS0122: `DotNetPlatform' is inaccessible due to its protection level
  • @Dalu have you downloaded the SDK on an empty project or are you upgrading your installation?

    If you are upgrading, please follow these instructions:

    If you are importing into a new project, try to restart the Unity Editor after the first installation.
  • DaluDalu
    edited September 2018
    It is a new empty project (android) and restarting unity doesnt help
  • @Dalu Are you following the updated tutorial mentioned above? It's far from perfect, but I was able to figure out what I needed to get things to work after several hours of effort...
  • Hello - I upgraded from to, and I am getting the "BoltNetwork.Connect(UdpKit.UdpEndPoint, Bolt.IProtocolToken)' is inaccessible due to its protection level" error.

    I followed the steps linked above ( and I am still getting the error.

    I am upgrading a current project.

    I've gone through the upgrade steps around five times and get the same error at the end of each upgrade.

    When I complete the upgrade, I compile Bolt and then I need to go into the bolt/packages/ folder and also install "bolt_install" in order to get rid of some other errors.

    The last error is the BoltNetwork.Connect error, which has completely halted my progress.

    Is there anything else I can attempt, short of starting a new project an importing all my scripts and assets over?


  • I should state that the reason I was forced to upgrade was because I was unable to switch Bolt from Debug mode to Release mode - the selection was simply just not there. Therefore, I though an upgrade was the only way to add the ability to switch. If someone could explain to me a trick to get ver to go into release mode, I'd be happy to remain at that version.

  • I just tried creating a new project with Bolt, and I'm getting the same error on "BoltNetwork.Connect"... this leads me to believe it's not my project that is causing the issue.

    Has this function been depreciated?

  • I did a bit more experimenting, and on my computer BoltNetwork.Connect() works only when using a Photon Session, not when using UdpKit.UdpEndPoint. I confirmed this by following the 101 tutorial. However, I require a self hosted server, so photon will not work for me.

  • Bolt free uses Photon Cloud integration. Bolt Pro has features like direct connect, console integrations, Zeuz integration, etc.

Sign In or Register to comment.