Photon View - incorrect name

Hello.
The "Photon View" component can't be added through the inspector because the name is spelled wrong somewhere.
https://imgur.com/a/QAGsJuK

But it can be added correctly through the top left component drop down.

Comments

  • Thanks for mentioning it can be added through the component drop down, you just saved me from a headache.

    Adding some info to the problem (at least as it exists on my end), trying to add the component through the inspector throws this specific error-

    ExecuteMenuItem failed because there is no menu named 'Component/Photon Networking/Photon View &v'
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
  • Hi @bibbis, @heavenlyalchemy,

    Thank you for choosing Photon!

    What PUN version and Unity versions are you using?
  • bibbisbibbis
    edited December 2018
    Hi,
    I'm really loving PUN, it's ridiculously easy to use.

    I'm currently on the latest version of Photon 2 (v2.5 (20th November 2018)) and Unity 2018.3.0f2.
    I've used several of the previous 2018.3 beta Unity version as well, and this has been a problem ever since I started using Photon a couple of months ago.

    Adding some info to the problem (at least as it exists on my end), trying to add the component through the inspector throws this specific error-

    ExecuteMenuItem failed because there is no menu named 'Component/Photon Networking/Photon View &v'
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

    I'm getting that error message as well.
  • JohnTubeJohnTube mod
    edited January 12
    Could you try removing the "&v" part in "PhotonView.cs":

    so instead of:
        [AddComponentMenu("Photon Networking/Photon View &v")]
    
    this:
        [AddComponentMenu("Photon Networking/Photon View")]
    
    EDIT: make sure to restart Unity after making the change.
  • @JohnTube Yeah that worked.
    When I change it and Unity recompiles, at first there are 2 PhotonViews:
    https://imgur.com/a/wILx1Sm

    But after closing and reopening the project, the "&v" version disappears.
    I'm not getting any errors or issues when adding or using PhotonViews now.

    Thank you for the help!
  • FunestoFunesto
    edited January 11
    I've got some troubles too ... I can't "Add Component" anymore :-( I also removed that "&v" but still nothing!

    EDIT: Wait, right now I restarted Unity ad it seems I can click again "Add Component"
  • Hi @Funesto,

    Thank you for choosing Photon!

    Did you try closing and reopening Unity Editor after removing "&v"?
Sign In or Register to comment.