The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on PUN.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

[PUN2/Local/Quest2] Can only connect to a specific local server with Oculus Quest 2 VR headsets

PascalTheDog
2022-03-04 18:05:56

A few months ago, I created a thread hoping to address an issue we were having connecting to a Photon local server (v5) with the Oculus Quest 2. Sadly, we weren't able to solve the problem at the time and we decided to set is aside for a while. Now we're back in business, and we tried proceeding by elimination in hope of identifying the issue once and for all.

First of all, we installed a local server on a whole lot of additional machines — both desktops and laptops. We then tried to connect to those local servers not from the Oculus Quest 2 but directly from the Unity Editor on Windows — and guess what, it has no trouble connecting to every last server on our local network, creating or joining rooms, etc. So it doesn't seem like our issue is related to the machines themselves, our wiring or our modem.

Going back to the Oculus Quest 2, we noticed that the first local server to which we successfully connected with a VR headset (which happens to have an IP address of 192.168.1.35) is the only one that continues properly operating as such. None of the other local servers will let us connect; not a single one but the one with a .35 address. As far as I know, all local server files are fresh installs with no difference in configuration. It's as if our venue had fallen victim to a curse except that one machine had been protected by a talisman.

Bummer: we're stuck in a dead end again. But then I noticed something strange: When I join a room in the Editor, in which I have access to the logs, I get a notification specifying the IP address of the game server thanks to the Photon support logger. The first is what I get with the only machine that works with VR headsets; the second is what I get with all other machines.

[1:56.56] SupportLogger OnJoinedRoom(Room: 'NetworkTesting' visible,open 1/4 players.). GameServer:192.168.1.35:5056

[3.328] SupportLogger OnJoinedRoom(Room: 'NetworkTesting' visible,open 1/4 players.). GameServer:127.0.0.1:5056

For some reason, only the 192.168.1.35 IP address is described explicitly; that of the local server that works fine with headsets. All the other as you can see above are described simply as localhost. This might be unrelated or irrelevant, but we couldn't help but notice the coincidence.

We're kinda baffled and asssistance would be greatly appreciated. Cheers!

Comments

PascalTheDog
2022-03-16 14:23:43

We haven't been able to make any progress on solving that issue and we have a deadline closing in. Any idea? :(

Tobias
2022-03-21 15:26:58

I'm sorry to read you're blocked by this issue for so long. Not great.

If you want to host Photon yourself, you need to realize that the same configuration won't work on any two machines. This is because you have to define the IPs under which the Master Server and Game Servers should be reached. Different machines have different IPs.

With an IP of 127.0.0.1 (the local machine) set for Master or Game Server, you tested that clients can connect to some of your server, then connect to the Photon instance running on the very same machine.

The Quest (or any mobile for that matter) won't be able to give you the same illusion, as it doesn't run the Photon Server.

Follow the doc about setting up the server IPs. When reporting connection issues, make clear if you don't connect at all (not even to a Name Server) and where you are stuck exactly. This helps us tremendously to help you.

PascalTheDog
2022-04-20 10:46:11

My apologies for the late reply, we were very busy working on an essential deliverable. :(

I did repeatedly try redefining the IP addresses referenced in the config files back then, but it didn't seem to change anything.

I have made a fresh install on my home setup, not changing anything in the server files. I have the Unity project on my desktop computer, and the Photon server on my laptop — both are connected to the same router using WiFi. No server is running on my desktop computer.

I have no issue connecting to the laptop server (IP address: 192.168.127.1.11) from my desktop project (IP address: 192.168.1.2) in the Editor. That's even though I haven't touched anything in the config files; they all still say 127.0.0.1. If I try connecting to the IP address of the desktop computer, I naturally get an error since there is no server to connect to.

So I'm not quite sure I understand. If the referenced address in config files is still localhost and that can be a problem (if I interpreted your message correctly), shouldn't the desktop project fail to connect to the laptop server altogether? There is no server on the desktop computer.

I'll try this out with a Quest 2 ASAP.

DEan
2022-07-20 15:54:53

did you find an answer to this?

I think I'm having the same issue, my on premise server works great with all my vive pro pc builds. It's all setup correctly but on the quest 2 I get this in the device logs:

Receive issue. State: Connected. Server: '127.0.0.1' ErrorCode: 10061 SocketErrorCode: ConnectionRefused Message: Connection refused System.Net.Sockets.SocketException (0x80004005): Connection refused

I noticed the 127.0.0.1 and thought why would it say the server is on localhost...

Back to top