Steam authorization with photon self-hosted server?

How do you setup a self-hosted server with Steam authorization. I modified my config file “Photon.LoadBalancing.dll.config” and added the following:
  <AuthSettings Enabled="false" ClientAuthenticationAllowAnonymous="false">
    <AuthProviders>
      <AuthProvider Name="Steam"
                    AuthenticationType="1"
                    apiKeySecret = "My API key"
                    appid = "<My AppID>"
                    verifyOwnership = "true"
                    verifyVacBan = "true"
                    verifyPubBan = "true"
                    RejectIfUnavailable = "false" />-->
    </AuthProviders>
  </AuthSettings>
However, with this change, the server can no longer start. Any help would be appreciated!

Comments

  • JohnTubeJohnTube mod
    edited March 22
    Hi @undercover,

    Thank you for choosing Photon!

    - You should know Photon Steam Authentication (as shown on this page) is not available for Self-hosted Photon Server. It's a cloud only feature. However, you could try your luck by asking via [email protected] (the answer is probably no still). The thing is that the Auth URL (provider/service) is hosted by Exit Games and not "public". You may implement one yourself and in this case no need to keep the same settings (key names and number) as ours.
    - I don't see how the config change causes server to stop working. Which file exactly is this (game or master server) and in which parent tag did you add this? Maybe there are duplicate auth settings in the same file?
    - I see that the auth settings are not enabled Enabled="false". Is this expected?
  • Ok, I see. It's the Master server config.
  • Implemented my own Photon Steam Authentication. Think I had some error in the config, never mind, it works now. Thanks anyway!
Sign In or Register to comment.