opLeaveRoom sometimes return an error code 1043

edited December 2017 in Native
I am using opLeaveRoom as a host to leave a room that the host created, and what should happen after is I get a leaveRoomReturn from the LoadBalancer.

However, I only get leaveRoomReturn calls sometimes. Other times Photon returns ConnectionErrorReturn, and the error code is 1043.

What is error code 1043? How do I fix this problem?

Comments

  • Hi @mantracker.

    You can look these codes up in Photon-cpp\inc\Enums\StatusCode.h.

    1043 means "disconnect by server logic". This means a) that this was not a socket-level error, but the Photon server purposely closed the connection and b) that the servers reason for closing the connection was neither the CCU-limit (that would be code 1042) nor a timeout (that would be 1041), but something else.

    Can you reproduce this with one of our demos (using one of the console demos from the demos folder inside the Client SDK when trying to reproduce this might make sense, as its usually easier and quicker to test, modify the code and play around with those demos as no full-blown engine like UE is involved)?
  • Hi @Kaiserludi

    I fixed this problem recently. The problem was a timing issue in our game code where we were not waiting for leaveRoomReturn to be called before changing maps.

    I have a new problem though, where sometimes calling opCreateRoom returns error 1040. I've looked around and it seems that this error is a pretty common disconnection error, and that there is a list of possible solutions here

    I've tried most of them and they don't seem to make a difference, and 1040 only came up for a short while, and now everything is fine. Since our multiplayer exclusively relies on this working, what can I do to resolve this problem that only comes up sometimes
  • Hi @mantracker.

    We had some server issues on Photon Cloud on the 11th of December (please see https://twitter.com/exitgames).

    If you got those 1040 errors during that time, but not afterwards, then this was probably the cause.
  • edited December 2017

    Hi @mantracker.

    We had some server issues on Photon Cloud on the 11th of December (please see https://twitter.com/exitgames).

    If you got those 1040 errors during that time, but not afterwards, then this was probably the cause.

    Thanks a lot, look like everything is fixed now!
Sign In or Register to comment.