webgl deployment problem (private messages)

Hi, I have a chat subsystem working ok on standalone builds, problem is on webgl, I can't send out privetae messages.

Is there a specific configurartion I have to consider / do something else?

Regards.

Best Answer

  • paxmx
    paxmx
    edited April 7 Accepted Answer
    edited:

    Changed chat user from current user and it's working now. Thanks for your help.
    Hi, thanks for your response. On questions:

    - Client: Pun2
    - Unity 2019.4.23f1
    - There's nothing in the logs (if you mean unity debug log / errors)
    - Can Send .cs class and live link if helpful.

    Code takes userid (which is the same used for pun). Does it matter?


    Ppublic messages do work (both standalone and webgl).

Answers

  • JohnTube
    JohnTube mod
    edited April 7
    Hi @paxmx,

    Thank you for choosing Photon!

    Which Photon Chat client SDK do you use? is it the one in PUN2?
    Which version?

    I'm assuming you use Unity? which Unity version?

    How to reproduce?
    Do you see something in the logs?

    You mentioned private messages not working on WebGL, did you test public channel messages?
  • paxmx
    paxmx
    edited April 7 Accepted Answer
    edited:

    Changed chat user from current user and it's working now. Thanks for your help.
    Hi, thanks for your response. On questions:

    - Client: Pun2
    - Unity 2019.4.23f1
    - There's nothing in the logs (if you mean unity debug log / errors)
    - Can Send .cs class and live link if helpful.

    Code takes userid (which is the same used for pun). Does it matter?


    Ppublic messages do work (both standalone and webgl).