Having Issues with PUN Namespace in VS2019

Good day, I am seeking some assistance. I don't know what else I can try do solve this issue.

I am using the latest PUN from the Asset Store

I am using Unity 2019.3.12f1
and Visual Studio 2019

When I attempt to edit any scripts VS complains that it can't find the Photon namespace. It's driving me nuts, I seem to be wasting too much time with this issue.

The type or namespace name 'Realtime' does not exist in the namespace 'Photon' (are you missing an assembly reference?) PhotonUnityNetworking.Utilities C:\Repos\SRP_Graphs\Assets\Photon\PhotonUnityNetworking\UtilityScripts\Prototyping\ConnectAndJoinRandom.cs 23

I tried
deleting all csproj, sln and .vs files/folders, restarted
deleting above plus Library folder
Removing the asset completely and reimporting.

HOWEVER, Unity itself doesn't complain and it complies correctly.

If I use Visual Studio Code it seems to not complain but I can't use VSCode due to lack of debugging and various VS2019 tools.

It seems to be something to do with VS2019? I can only assume but I can't find anyone else with the same issue. It was working just fine the day before, I re-opened it and now I have this issue.

Any suggestions would be GREATLY appreciated.


It does see these namespaces, but only these ones.

using Photon.Pun;
using Photon.Pun.UtilityScripts;


  • Looks like a Unity issue. If I open the project with 11f1 it works fine but fails to see PUN namespaces with 12f1..

    Can't explain it, but that is how I solved it, just revered to 11f1

    hope this helps someone
  • Me too. I have 2020.1.8f1, and due to dependencies I can't revert to such an old version.