Can't make a build in Unity using Photon Voice - "plugins colliding with each other"

Anyone else getting this error when they try to build their scene with Photon voice? Seems to be some issue with the opus_egpv.dll file.

I've tried it both in my project, attempting to build my main scene, and in a completely empty project with only Photon Voice, attempting to build their demo voice scene.

In both cases I'm unable to finish the build unless I delete the opus_egpv.dll file from the x86_64 folder.
When I do so, I'm able to run the game successfully for the first user. However, the game will crash for the second user as they try to join in. The second user's game crashes by freezing completely, requiring that I force exit it (this does not affect the first user).

I've tried this with both Unity 2017.3.0f3 and Unity 2017.2.0f3 to the same effect. I'm using the [currently] most recent version of Photon Voice, ver. 1.13 (released Nov 22, 2017). I am making a multiplayer VR game.


  • Mate

    This is a common general problem in Unity.

    Typically this is because you have two versions of the opus_egpv.dll installed

    Delete one that you are not using either the one in assets/plugins/x86_64 or assets/plugins/x86

    Or look at each ones import settings in the inspector and make sure that only the appropriate platform is selected for that plug in... x86 for the one in x86 and the same for the other

    Good luck and happy new year
  • JohnTube
    JohnTube mod
    edited January 2018
    Hi @PygmalionTheus,

    Thank you for choosing Photon!

    As @VRCraftworks mentioned (thanks btw!) it is a matter of plugins import settings per platform and configuration.

    Here is some info from an old forum post:

    - All files under "Assets\Plugins\x86" should have platforms "Standalone" and "Editor" only and CPU: "X86".
    - All files under "Assets\Plugins\x86_64" should have platforms "Standalone" and "Editor" only and CPU: "X86_64".

    I thought we have fixed this in v1.13 but maybe the meta files are not the same between Unity 5 and Unity 2017 or we missed something.

    I apologize about the inconvenience we will try to avoid this in the future.
  • This solution worked out perfectly! Thanks so much for the help.
  • @VRCraftworks you are best! Thanks! It helped me. I'm trying to solve his problem over 2 weeks.