Setting other network config error

Hey TrueSyncTeam,
In version 1.0.9 when starting your demo, choosing "KickingHeads", setting other values for the config and then starting the game throws some errors:


It seems setting other config values also forces the TrueSyncConfig to don't use Physics2D.

Full error message:
You have a 2D object but your Physics 2D is disabled.
UnityEngine.Debug:LogError(Object)
TrueSync.PhysicsWorldManager:AddBody(ICollider) (at Assets/TrueSync/Unity/PhysicsWorldManager.cs:103)
TrueSync.TrueSyncManager:InitializeGameObject(GameObject, TSVector, TSQuaternion) (at Assets/TrueSync/Unity/TrueSyncManager.cs:525)
TrueSync.TrueSyncManager:initBehaviors() (at Assets/TrueSync/Unity/TrueSyncManager.cs:305)
TrueSync.TrueSyncManager:Start() (at Assets/TrueSync/Unity/TrueSyncManager.cs:277)

Comments

  • Fixed it by adding the following lines to the StartMatch method:
    TrueSyncManager.TrueSyncCustomConfig.physics3DEnabled = false;
    TrueSyncManager.TrueSyncCustomConfig.physics2DEnabled = true;

    Maybe you can find a solution that takes the value of the set custom config in the TrueSyncManager script at the TrueSyncManager in the hierarchy.
  • Hi @John05, it should be fine only mark on the config inspector view which physics you are using. Did you face this problem in a fresh pack downloaded from asset store?
  • Hi @JeffersonHenrique,
    Yes. I made a fresh project, checked out TrueSync (1.0.9), added all Demo Scenes to the build settings.
    Then did as described above: "starting your demo, choosing "KickingHeads", setting other values for the config and then starting the game throws some errors:"
Sign In or Register to comment.