WTH??

ive forwarded port 5055, ive run the game on my computer and it works fine, but now ive transfered the game to 5 different computers and i get the same result every time..

it finds the room from all the other computers (so im assuming its not a connection issue) but when i click join that room it just sits at connecting..

im really interested in buying the indie version this week hopefully, but im having little issues...

thank you

Comments

  • The server for Photon Unity Networking is loadbalanced, so it uses a Master (which is fine, apparently) and a Game Server (which is not fine yet).
    You need to setup the game server's IP in a config file, according to your server's (public) IP.

    Sorry for the hassle. There seems to be no simple(r) solution to this, as a game server can't find its own public IP. Even it would ask whatismyip.com, this might not be the IP you want to use for game clients.


    From the pdf in the package (topic 2.1):
    The Game Server has a separate configuration for the IP that clients should connect to. The reason: The Master forwards only a single IP to clients to enter a room / game. The local IP: 127.0.0.1 is used here by default.

    To enable client connections from other machines, edit “PublicIPAddress” in:
    \LoadBalancing\GameServer1\bin\Photon.LoadBalancing.dll.config and
    \LoadBalancing\GameServer2\bin\Photon.LoadBalancing.dll.config