Unity 5.4.0b25 and Voice 1.4 on iOS

Hello,

Here is my problem, when I launch the demo of Voice, the runtime break on the opus lib.
Here is a screenshot in xcode : http://littlebigben.fr/xcode_punvoice.png

To reproduce the bug, just create a new project, import PunVoice 1.4 and build for iOS.

Why do I use the Unity beta?
I needed to update Unity to 5.3.5 to be able to publish on Apple store (because of the ipv6....).
But my project is a VR one, so in the latest stable versions of Unity the UI doesn't work with the Google Cardboard SDK (because of Unity RenderTexture issue).
So they solved it on the beta version!

Thanks for your help,
Benjamin

Comments

  • vadimvadim ✭✭✭
    Hi,

    Does it fails the same way if exported from Unity of latest release?
    What if use Unity beta but export for other platform (macos e.g)?
    Does it work in editor?
  • Hi,

    I tried on Andoid (no problem) and in the editor everything is fine.

    I'm only working under iOS and Android.
  • Sorry I forgot the first question, I didn't try on other realease, because there is a huge issue under 5.3.x versions (about world UI).
  • I just tried with the last version of Unity 5.4.0f1, same issue.
  • This conversation is being continued by mail.
    So far: Unity release 5.3.6 (mac) is working. Maybe it's a beta bug.

    The UI bug in 5.3 is not getting fixed by Unity?
  • Exactly the same for me, iOS. Seems fine on Android. Using Unity 5.3.6f1 although only Photon Voice v1.1. Will upgrade and post again if the
  • strikkystrikky
    edited July 2016
  • Our main developer for the Voice plugin is currently on vacation, so we're not as fast as I would hope.

    I will talk with my colleagues and see if we can re-build the plugin for iOS and I will try to reproduce the issue. Maybe I can post some fix. In worst case, this can only be fixed next week.

    One detail question: Does the issue happen right away and always? Or do we need to run this a while?
  • strikkystrikky
    edited August 2016
    Hi Tobias,

    For me, straight away, as in, as soon as the codec appears to be used.

    Seems to still work fine on version 5.3.4, but I need to upgrade to 5.3.6 sooner rather than later because my app is suffering from the same Unity UI bug benjamin mentioned.
  • If it's working in 5.3.4 but not in newer versions, please report a bug to Unity. This might be completely out of our reach and due to internal issues in the exported player.
    Let us know the case number and we can try to push this.
  • vadimvadim ✭✭✭
    Reproduced in Mac Unity 5.3.6f1 on iPhone 5.
    Please try new iOS opus library build: https://www.dropbox.com/s/y9qnps1rwyqki0e/libopus_egpv.a
    Replace \Assets\Plugins\iOS\libopus_egpv.a with downloaded file.
Sign In or Register to comment.