[SOLVED] Building error

shftdshftd
edited June 2016 in Photon Voice
Hello everyone,
I have a problem when building my UWA project with the last version of Photon Voice plugin: each time, I get an GetFileByPath(filePath) == NULL UnityEditor.HostView:OnGUI() error.

I also tried to build the demo scene on an empty project in UWP but still the same error.
Unity Version: 5.4.0b18

image


Thanks

Comments

  • shftdshftd
    edited June 2016
    I just checked with only the PUN asset and I have the same error.

    If it can help, I found this in my Editor.log:

    GetFileByPath(filePath) == NULL UnityEditor.BuildPipeline:BuildPlayerInternalNoCheck(String[], String, BuildTarget, BuildOptions, Boolean) UnityEditor.BuildPlayerWindow:BuildPlayerWithDefaultSettings(Boolean, BuildOptions, Boolean) (at C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindow.cs:541) UnityEditor.BuildPlayerWindow:BuildPlayerWithDefaultSettings(Boolean, BuildOptions) (at C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindow.cs:403) UnityEditor.BuildPlayerWindow:GUIBuildButtons(IBuildWindowExtension, Boolean, Boolean, Boolean, BuildPlatform) (at C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindow.cs:1456) UnityEditor.BuildPlayerWindow:ShowBuildTargetSettings() (at C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindow.cs:1391) UnityEditor.BuildPlayerWindow:OnGUI() (at C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindow.cs:959) System.Reflection.MonoMethod:InternalInvoke(Object, Object[], Exception&) System.Reflection.MonoMethod:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222) System.Reflection.MethodBase:Invoke(Object, Object[]) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MethodBase.cs:115) UnityEditor.HostView:Invoke(String, Object) (at C:\buildslave\unity\build\Editor\Mono\HostView.cs:187) UnityEditor.HostView:Invoke(String) (at C:\buildslave\unity\build\Editor\Mono\HostView.cs:180) UnityEditor.HostView:OnGUI() (at C:\buildslave\unity\build\Editor\Mono\HostView.cs:76)
  • Are you both using Unit 5.4 Beta?
    Are you using just the demo? Is it IL2CPP or Mono?

    We tested Voice only with 5.3. We can look into the beta but overall, the focus is on 5.0 to 5.3.
  • Hi @Tobias
    thank you for the reply.

    I'm using Unity 5.4.0b18.
    I'm just using the demo.
    I'm not quite sure what you are asking but if you're talking about Scripting Backend option, i'm using .NET

    The problem is not only from the Voice feature as I tested it with the PUN plugin (imported from the store on a new project) and still have the same error when building.
  • This really looks odd.
    I fear we can't do much about it. I'm not aware of anything special in our code, that is now forbidden in 5.4.
    Please report this as bug to Unity and post it in their "beta" forum. Maybe there is a workaround.
    You can submit out demo package as repro case.

    This is very very likely out of our reach.
  • shftdshftd
    edited June 2016
    Indeed, it worked well with the 5.3.5 .
    For those interested in the issue, I posted a thread here [1]
  • Updating to 5.4.0b20 solved the problem
Sign In or Register to comment.