Echo on Demo

iARiAR
edited March 2016 in Photon Voice
Hi, I have test the Demo but i have a lot of echo. I disable the audio source of "our" player prefab. It doesn't make sense for me to reproduce my own voice.

So I added the next line on CharacterInstantiation
o.GetComponent<AudioSource> ().enabled = false;
just below of
o = PhotonNetwork.Instantiate(o.name, spawnPos, Quaternion.identity, 0);

Its that correct or Im missing something?

Comments

  • JohnTubeJohnTube mod
    edited March 2016
    Hi @iAR,

    First please make sure DebugEcho toggle from "In-Game Settings" is disabled (unchecked/unticked).
  • iARiAR
    edited April 2016
    Hi @JohnTube
    I try it with DebugEcho disabled but It didn't fix the echo issue.
    Removing the audio source and using headphones make it works like a charm. But without headphones is imposible to use it on an mobile phone.
  • vadimvadim ✭✭✭
    Hi,
    So what is the scenario? You start single client and hear echo of what you are speaking?
    Are you sure that removing audio source required to cancel echo? Using headphones should be enough since it prevents getting incoming audio from speakers to microphone. But this is true for audio received from other clients of course. How client own audio could be echoed is still not clear for me.
Sign In or Register to comment.