Problems with the Unity Asset Store packaging

mizanyx
edited September 2011 in Photon Server
Hi all.

I am currenty working in a project that involves Unity3D and Photon Socket Server. I'm using Photon 3.0 RC3 and Unity3D 3.4. I tried to use the templates available in the Asset Store to kickstart the project, but...

The "Photon Viking Demo" doesn't even show a download button in its Asset Store page.
The "Photon Unity Networking" script demo was downloadable, and worked fine locally. But when i changed the address in MainMenu.cs to the address of other box in my network, who was running the Photon-Server provided in the package, it didn't worked, giving out the following error:
Error trying to receive. Exception: System.Net.Sockets.SocketException: Se ha forzado la interrupción de una conexión existente por el host remoto.

  at System.Net.Sockets.Socket.Receive (System.Byte[] buffer) [0x00000] in <filename unknown>:0 
  at ExitGames.Client.Photon.NConnect.Run () [0x00000] in <filename unknown>:0 
UnityEngine.Debug:LogError(Object)
PhotonHandler:DebugReturn(DebugLevel, String) (at Assets/PhotonNetwork/PhotonHandler.cs:82)
NetworkingPeer:DebugReturn(DebugLevel, String) (at Assets/PhotonNetwork/NetworkingPeer.cs:669)
ExitGames.Client.Photon.<>c__DisplayClass2:<EnqueueDebugReturn>b__0()
ExitGames.Client.Photon.EnetPeer:DispatchIncomingCommands()
ExitGames.Client.Photon.PhotonPeer:DispatchIncomingCommands()
PhotonHandler:Update() (at Assets/PhotonNetwork/PhotonHandler.cs:48)
To check out if it was a problem of network connectivity, i downloaded the full 3.0 Photon Server package in the 'server' box, and ran the Instance1. Then I downloaded the Photon DotNet 3.0 SDK in the 'client' box and compiled the 'demo-realtime' application, changing the address from 127.0.0.1 to the address of my 'server' box. I ran 3 instances of 'demo-realtime' and I saw 3 small squares moving randomly in the second tab. So it was surely not a firewall problem, as the connection was made via UDP from client to port 5055 of server, across the two boxes.

I'm now stuck trying to figure the real problem. Any help? I've read all the threads in this forum talking about similar problems and its supposedly caused by routing or firewalls. But as i sucessfully made a connection between instance1 and demo-realtime, this cause can be discarded.

Both machines are in the same wireless local network, and are in the same Hamachi network. I've tried to use bot the Hamachi address and the LAN address of the server, but no luck.

Thanks in advance.

Comments

  • Sorry for posting in the wrong section.
    The answer was in this thread:
    http://forum.exitgames.com/viewtopic.php?f=17&t=671
    I changed the
    <setting name="PublicIPAddress" serializeAs="String">
    to my IP and it worked like a charm.
  • the download button for the viking demo shows only if you have installed unity 3.4.
    for some reason when you had unity 3.3 pinned to the task bar it keeps starting as unity 3.3, so you might need to update your shortcuts.

    Next pitfall was a buggy local IP address: the downloaded viking demo has IP 127.0.0.11 configured in MainMenuVik.cs. change this to 127.0.0.1