Activate server

maimai
edited August 2011 in Photon Server
Hi everyone , i have just started using photon with unity 3d. I am trying to test my server with the demo lite lobby chat room . i have downloaded the sdk in my server and started the photon as service but i cannot connect via the wan (the status is always disconnected).
PS: the firewall is disabled and i opened port 5055 .
Can any one help me please it has been 2 days :(

Comments

  • Launch the "Photon Control.exe" and check if photon is running.
    Then check with the same control the logs (Photon Control -> Open Logs)
  • "i cannot connect via the wan"
    You mean wireless lan? It could be an issue that the server is not accessible to your device, if it's not in the same wlan. Some routers do not automatically route between wlan and lan IPs.

    Your client needs to connect to an IP (or host address) that is reachable for it. So, also check the values you use in Connect().
  • wan i mean via internet i have a static ip adress
  • Maybe there is a hardware firewall before your server? This depends on who is hosting your machine.
    You are sure you used the machine's public IP in your client?
    You could try your client locally on the same machine with the public IP.
  • i am not sure about the hardware firewall i will check it. i am sure i used the public ip and i tried it locally it worked fine .
  • thank you for your help it was a problem with the server port once we re-config it it worked smoothly :D
Sign In or Register to comment.