Custom auth error?

edited June 2015 in DotNet
I have been trying to get custom auth to work.
My login script on my webserver works fine (tested with postman)
On unity i only get "Custom Authentication failed (either due to user-input or configuration or AuthParameter string format). Calling: OnCustomAuthenticationFailed()"
My OnCustomAuthenticationFailed says: "Custom authentication service error: Error".
Any ideas?
I need help as fast as possible.

Comments

  • Did you check if your custom auth service got called? Did you make sure there is no error in what you return to Photon when you auth a user?
    Is your forum mail address the one of your Cloud Account? Can we find your app with it?
  • Tobias wrote:
    Did you check if your custom auth service got called? Did you make sure there is no error in what you return to Photon when you auth a user?
    Is your forum mail address the one of your Cloud Account? Can we find your app with it?
    Yes. My email is same as the email on the forums xD
  • Did you check your logs for the PHP file?

    You defined key/values for your "username" and "password" for the Custom Authentication in our Dashboard. This could potentially collide with values you actually want to send from the client and cause the issues.
    Remove those key/values and try again.
    The key/values are useful when Photon has to send some verification to access your restful service. It's not a definition of what the client is allowed (or required) to send.
Sign In or Register to comment.