Error when building for wp8

edited April 2015 in DotNet
Hi. I`m trying to build our game for wp8 platform and it fails with this:
Error building Player: Exception: Failed to run serialization weaver with command line "Temp\StagingArea\Data\Managed\Photon3Unity3D.dll" -pdb -verbose -unity-engine=Temp\StagingArea\Data\Managed\UnityEngine.dll "Temp\StagingArea\TempSerializationWeaver".[Temp\StagingArea\Data\Managed\Photon3Unity3D.dll]
Symbols will be read from Temp\StagingArea\Data\Managed\UnityEngine.pdb
Weaving assembly E:\Work\GameName\Temp\StagingArea\Data\Managed\Photon3Unity3D.dll
Symbols will be read from Temp\StagingArea\Data\Managed\Photon3Unity3D.dll.mdb
Mono.CompilerServices.SymbolWriter.MonoSymbolFileException: Symbol file `E:\Work\GameName\Temp\StagingArea\Data\Managed\Photon3Unity3D.dll.mdb' does not match assembly `E:\Work\GameName\Temp\StagingArea\Data\Managed\Photon3Unity3D.dll'
at Mono.CompilerServices.SymbolWriter.MonoSymbolFile.CheckGuidMatch(Guid other, String filename, String assembly)
at Mono.CompilerServices.SymbolWriter.MonoSymbolFile..ctor(String filename, ModuleDefinition module)
at Mono.Cecil.Mdb.MdbReaderProvider.GetSymbolReader(ModuleDefinition module, String fileName)
at Mono.Cecil.ModuleReader.CreateModuleFrom(Image image, ReaderParameters parameters)
at Mono.Cecil.ModuleDefinition.ReadModule(String fileName, ReaderParameters parameters)
at usw.Weaver.WeaveAssembly(String assemblyPath, AssemblyDefinition unityEngineAssemblyDefinition)
at usw.Weaver.Weave()
at usw.Program.RunProgram(ConversionOptions options)
at usw.Program.Main(String[] args)

On other platforms (Android, IOS) it works fine. I use latest version 1.51.
Thanks for any help..

Comments

  • This looks like a problem in the build process. As it's working on other platforms, I think it's best to report this as bug to Unity.
    Try the latest version of Unity maybe, including the patch releases:
    http://unity3d.com/unity/qa/patch-releases

    Which Unity version did you use?
  • Try deleting the temp folder and re-build. I've run into this with external libraries from time to time on most platform builds.
Sign In or Register to comment.