3 errors when implementing to Unity3d

edited September 2014 in Photon Chat
Hi, when I tried to implement into my project I just get this 3 errors:

2H5vGV.jpg

Anyone can help me? dunno whats going on. (Sorry Im really new to this).

Comments

  • Make sure you have the latest versions of PUN and Chat.
    See:
    http://forum.unity3d.com/threads/photon ... st-1778859
  • Hi.
    I also just tried to install and test the chat demo, and I have the same errors. I downloaded the SDK's from here : https://www.exitgames.com/en/Chat/Download and tried to launch the chat demo project.

    Help please, I don't know what I'm doing wrong :oops:
  • Sorry. I didn't notice you were using the Chat Demo. I expected this to be used in PUN.

    When we adjusted Chat for PUN and PUN+, we obviously made a mistake and broke the Chat Demo.
    To fix it, go to ChatClient.cs and finde "#if UNITY" (should be line 110). Make it check: "#if UNITY && PUN".
    That should fix your issue but it won't work in PUN with that check. So far, Photon Unity Networking v1.27 does not define a PUN compiler value.

    I should be able to update the SDK later today.
  • I released v4.0.0.4 with a fix for this issue. I hope it's all seamless now. Let me know and sorry for the inconvenience.
  • ty very much.
Sign In or Register to comment.