ClassDefNotFound Error when trying to use SDK

edited September 2014 in Android Java (deprecated)
For some reason the android application is never able to find the classes from the photon-android.jar file during runtime. There are no errors in the IDE or during compiling however when I run the application I always get ClassDefNotFound error if I use any classes in the photon-android.jar file. Is there a specific way to import this into the android eclipse project? Or are there some settings that I need to change to make the application recognize this .jar? I have already tried the following:

-Add photon-android.jar as an External Jar and Check it in the Order & Export window to make sure it is exported with the application.
-Put the photon-android.jar file into the project's "libs" folder.
-Changing the ordering of the photon-android.jar in the Order&Export properties.
-Android Tools > Fix Properties
-Clean Project

None of the above work and it always gives me the same error.


  • Tobias
    We have to take a look asap. My colleague for Android isn't here today but I know there is a way to make it work.
    Are you using the IntelliJ-based IDE?
  • Hi, we don't support Eclipse IDE directly. We use IntelliJ-based Android Studio for development. You can probably ask for help with setup on Eclipse forums.