Installed new PUN 1.18.1 now my instantiates aren't working

So I installed the new PUN. And now my instantiates aren't working. They worked fine before.

Here is my code... please advise, this worked fine with 1.17. There are no errors being logged from PhotonNetwork code... it just seems that it's always returning null.

object[] data = new object[1];
data[0] = instantiationData;

GameObject go = null;

if (sceneObject)
{
go = PhotonNetwork.InstantiateSceneObject(resourceName, pos, rot, (int)netLevel, data);
} else {
go = PhotonNetwork.Instantiate(resourceName, pos, rot, (int)netLevel, data);
}

return go;

Comments

  • It appears it's getting booted out of NetworkingPeer.cs here:

    // SetReceiving filtering
    if (group != 0 && !this.allowedReceivingGroups.Contains(group))
    {
    return null; // Ignore group
    }
  • I figured out... I was using groups to group the instantiates... they were never activated (but were never deactivated either).

    Something is different between 1.17 and 1.18 where it requires to activate them explicitly I guess...