[SOLVED] No rooms, can't join even if they exist

I've downloaded the latest Photon viking example for Unity, Compiled and ran it with my Free plan app ID, then opened two instances of the game (tried both Compiled+Compiled and Compiled+Editor). I created a room in instance A and open instance B, but it says no rooms are available, and when I try to join the room with the same name of the one created in instance A, it gives this error:
[code2=plain]joinGame failed, client stays on masterserver: OperationResponse 226: ReturnCode: 32758 (Game does not exist). Parameters: {}. State: Authenticated
PhotonHandler:DebugReturn(DebugLevel, String) (at Assets/Photon Unity Networking/Plugins/PhotonNetwork/PhotonHandler.cs:127)
NetworkingPeer:DebugReturn(DebugLevel, String) (at Assets/Photon Unity Networking/Plugins/PhotonNetwork/NetworkingPeer.cs:709)
NetworkingPeer:OnOperationResponse(OperationResponse) (at Assets/Photon Unity Networking/Plugins/PhotonNetwork/NetworkingPeer.cs:889)
PhotonHandler:Update() (at Assets/Photon Unity Networking/Plugins/PhotonNetwork/PhotonHandler.cs:65)[/code2]
I did not modify any scripts from the package.


  • Nevermind, the problem is that I was targeting a 64-bit system in the Unity build settings menu.
  • Tobias
    Huh? I don't see yet why 64bit builds should fail this way but if this solves your case, that's ok.
    Were there any other debug log entries before the one you posted?