The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on Fusion.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

[SOLVED] Fusion linux dedicated server Segmentation Fault

KarimVoidstorm
2023-03-31 10:06:45

Hello,

I have a dedicated server build running on Unity Multiplay. Everything works fine in windows with my build, but when hosted on the Unity infrastructure, it happens to end with a segfault at seemingly random times.

Here is the stacktrace:

Again, everything works perfectly on windows. at first I thought that the server the build was running on went low on resources, but after benchmarking how much RAM it used, everything should have been fine. My RAM usage on windows barely goes above 200MB and my server has 800MB allocated. I even tried allocating more, with 2GB RAM servers, but sadly got the same results.

I'm not sure whether the issue comes from Unity or Fusion, so I'm also asking the question here. I thoroughly searched for people who may have the same issue and found a few segfaults of dedicated fusion servers running on linux but none of the stacktraces I fell upon looked like mine.

Thanks in advance.

Comments

KarimVoidstorm
2023-03-31 16:32:39

I've been compiling with Mono. After switching to il2cpp, the segfault disappeared.

Back to top