can I download older version sdk v4.1.15.2 ?

Is there any availability of older version of sdk download?

I need android_ndk sdk v4.1.15.2.


  • Hi @jeevs.

    We normally don't provide older versions for download to encourage people to use the most recent ones.

    Is there any specific reason why you can't just use the latest version?

  • I am in big trouble.. I got stuck..

    I have an old game project in cocos2dx 3.16 for android and I integrated photon realtime v4.1.6.0, this was on testing phase for quite a long time but the multiplayer feature is working pretty fine right now.

    Now the problem is with cocos2dx 3.16 I can't set targetSdkVersion 31! only upto 30 is possible so far tried.. it's ndk build.. Google Play store accepts targetSdkVersion 31 and higher only.

    So I have to upgrade cocos2dx but with cocos2dx 3.17.2 (cmake build) previously working codebase/setups didn't work neither with old working sdk version nor with the latest version.

    So for the latest photon sdk v5-0-5-2, do you have any guidelines/workaround for c++/ndk based android development ?

  • Hi @jeevs.

    Why do you think you need a workaround?

    What kind of issue do you run into with that you did not face with and that you hope you will not face with as well?

  • Hi @Kaiserludi

    With the latest sdk I'm getting this error:

    error: allocating an object of abstract class type 'NetworkLogic'

    Can we communicate in email for more details?

  • Hi @jeevs.

    "allocating an object of abstract class type 'NetworkLogic'"

    That means that your NetworkLogic class does not implement all pure functions from LoadBalancing::Listener.

    At least one of those functions is either missing completely or does not have the correct number or types of parameters.

    For this kind of error the information that is shown in the Visual Studio "Error List" view isn't particularly helpful. However you can double click on the error in the "Error List" to view it in the "Output" view and in that view Visual Studio will actually tell you WHY the class is abstract aka which function/function-overload is missing.

    "Can we communicate in email for more details?"

    Sure. Just send an email to the address listed at and include an link to this forum thread in your email for context.

  • jeevs
    edited January 13

    Hi @Kaiserludi,

    The same thing is working with, may be there are a lot of new changes in I'll try to keep on checking.

    One more thing, the photon sdk linking up with main project is not working on windows.. with the same setup the sdk is linked up on Mac. My developer who mainly worked on photon part uses windows.

    I made cmakeLists.txt of loadbalancing-cpp and put the .txt file on photon sdk root folder then added that path to the cmakeLists of cocos2dx main project root folder. It's being linked up on mac but not on windows.

    On windows the codes with ExitGame are showing red with this msg "use of undeclared identifier 'ExitGames'" but the build error is same on both "error:allocating an object of abstract class type 'NetworkLogic'"

    Can you please help me on this for windows setup?

  • Hi @jeevs.

    You could compare at Listener.h from both SDKs in a file diff viewer to easily spot was has changed there.

    There should not be any need for rebuilding loadbalancing-cpp, as the SDK already comes with prebuilt binaries for it. Just have the CMakeList.txt of your app directly link to those libs.

    You could have a look at Demos/demo_particle/cocos2dx/CMakeLists.txt, Demos/demo_memory/cocos2dx/CMakeLists.txt or Demos/demo_chat/cocos2dx/CMakeLists.txt inside the Client SDK for an example of a cmakeLists.txt that can successfully find the libs.