How to turn off extrapolating in Photon Fusions NetworkRigidbody2D?

lennart862 ✭✭
edited September 2022 in Fusion


I have a problem with Fusion: Everything works fine, but as you can see in the screenshot the extrapolating causes problems when jumping or falling from height.

The player sinks into the ground and slowly within a few seconds comes back to ground level. When I set InterpolationDataSource in the NetworkRigidbody2D to NoInterpolation the character stops falling into the ground but it makes the ticks from Fusion very visable what makes it seem laggy.

I tried setting it to Snapshots or Predicted to see if that works and changed all the parameters one at a time but nothing stops it from extrapolating. The only thing that worked for me was turning the interpolation off and setting the tick speed to 128 but this takes up a lot of bandwidth.

Any help is much appreciated.



It seems, as if it only extrapolates into the ground, when the character gets no input on the x axes. When just jumping and then not moving right or left at all the character stays in the ground forever, until it gets x input. Could it be, that Photon tries to send so few messages, that it misses out on important information here?

Using v 1.1.1, Shared Mode, 32 Ticks/s, NetworkRigidbody2D, Physics Engine: Fusions 2D