Socket TimeOut

Aryoa
Aryoa
edited July 1 in Photon Server


In the testing phase, there would be two or three Socket Timeout every morning and then everything would be fine. I check the server log, as shown in the figure. Is it the reason that the server enters low power every six hours when there is no communication requirement from the client?

MSMaster.log

GSGame.log

and is there a way to cancel the low power state?

Answers

  • Meep
    Meep ✭✭✭

    Is this TCP protocol? for what reason are you using TCP and have you tried UDP? Do you get a ClientTimeout error when using UDP as opposed to TCP?

    The servers don't enter a low power state to my knowledge but I did encounter something similar to this but with the connection between the MasterServer and GameServer themselves, I asked the engineers about it but they confirmed the server doesn't become low power after a while.

    The text you highlighted in the red box is the loadbalancer changing load levels and does not mean the nodes have become docile.

  • hi, @Aryoa

    I confirm that there is no low power state on server. At least not in Photon.

    take a look on native logs in bin_Win64/log folder. it might be that they contain something useful


    best,

    ilya

  • I alse tried UDP,but maybe some ServerSettting is not correct,everytime I tried UDP,it keep 10 seconds that received connectToMaster callback and joinroom callback.so i give up UDP, this few days I cancel use NameServer, the questisions only comes up once every morning,I was forced to accept, Thank you very much for your answer

  • Maybe I can chech it Tomorrow morning,because it happens on the lowest status,if i save this problem,I will come back to Write down the solution. thank you very much for your answer.

  • hi, @Aryoa

    did you do any server side modifications?

    those 10 seconds delays are something very unusual. I do not remember anyone complaining about them

    May be you have to change your server provider


    best,

    ilya

  • I use the same server.in udp.it keep 10 seconds to connecttoMasterServer and joinroom,once joinroom,everything running well.but when i stop the programm and restart ,it also keep 10 seconds to joinroom. so i try tcp, 4530 port,its running well,connect fast Except the first time to break out lowst status(I can't find any correct words to describe the problem,So i used lowest status,Although you have already Clarify Server doesn't have any lowest status. sorry....)

  • looks like it doesn't have any useful log....the problem keep appear every morning i running programm.Maybe I Can solve the problem by create a room a few hours to keep server alive

  • hi, @Aryoa

    try to activate debug logging on Master before you do your first connection

    may be managed logs will revile the issue. managed logs placed into deploy/log folder. to activate debug logs you have to modify log4net.config in LoadBalancing/Master/bin folder


    best,

    ilya