Pun2 as a git package doesn't connect to the self hosted server on webgl build

Hello. I've been using pun2 for a while now for a project and I needed to "convert" it to a git package for dependency reasons. Since I did that I was unable to connect to a self hosted server set up on my pc. The files are completely the same as the original photon. Just for a sanity check I tested the asteroid demo on a new project and they worked fine as pun2 was in the assets but the same exact demo was unable to connect if pun2 was used as a package.

More specifically, the network client state doesn't progress beyond the "connecting to master" state. The problem occurs in webgl builds. I tried to build it for windows and it somehow worked. On webgl though, even with minimal/disabled code stripping and adding the photon link.xml file to the projects link.xml file I had no luck. I've also tried both simple websocket and the secure one (+ name server instead of master). Still same issue.

A thing I noticed is that the code does reach the part where the load balancing peer connect() function is called with the correct parameters, however the server's log files don't seem to receive anything.

Is there something I can to fix that? Any help would be much appreciated.

Thanks in advance!