The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on PUN.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

Photon pun Doesn't connect to master suddenly

sanaomer
2022-03-27 08:24:14

I've been using pun for 3 months now on a project and I never had any problem with connecting to master

but now suddenly it's either connects or just hangs in there no error no connection no nothing,

it keeps loading without anything happening and when I stop the game and restart it, it suddenly works

I changed network logging to All and pun logging to Full

the first image is what it looks like when it connects

and the second is what it looks like when it hangs in there

thanks for any help

Comments

Tobias
2022-03-28 13:33:49

The internet is not fully reliable. Sometimes servers or routes are down or so unreliable that no connection happens.

Please let me know if this is gone today.

sanaomer
2022-03-28 18:15:51

Tobias 2022-03-28T13:33:49+00:00

The internet is not fully reliable. Sometimes servers or routes are down or so unreliable that no connection happens.

Please let me know if this is gone today.

that's not seem to be my problem, I've never faced this issues before with pun connection, but it's only like that when I started adding MRTK Azure spatial anchor sample for multiuser experience using photon

and ever since it either connects or it just hangs in there

Tobias
2022-03-29 14:40:52

If that's related, you may want to figure out how much it sends or if it's a performance issue.

The Analyzing Disconnects doc might help you, which directions you should have on your radar for that.

sanaomer
2022-04-02 08:28:37

hey, I really need help, at this point I tried everything and I still can't find a way to solve this problem

I made a new unity project and tried a different script to connect still the same result, I opened my previews project they don't seem to work either, I changed the region, I made a new pun app on the dashboard with a new account still nothing, I used the reconnect method.

I'm also running out of time so if you help me fix this issue, ill be very thankful

sanaomer
2022-04-03 01:40:42

okay I managed to fix it turns out I was using the same app id on two different unity projects and I made a new app in the dashboard, it worked perfectly for couple of hours and now it suddenly stopped working in the editor it just never connects.

I tried restarting the editor

I changed the region

I reset and refresh RPCS

I tried reseting region

nothing works please help I'm losing my mind because of this :(

Tobias
2022-04-04 11:55:36

Please do read the link I sent you. The minimum you should do is enable the SupportLogger and figure out where and how the client is kept from connecting, creating a room or whatever.

Right now, I am lost. I don't know what the issue is.

sanaomer
2022-04-05 18:42:57

everyday a new issues sorry about that, but now when I built to mobile it works fine I tested on multiple mobiles and wifis but it doesn't connect on the editor!!

Tobias
2022-04-06 15:34:34

This is too vague. Look into the Getting Help doc and or the Analyzing Disconnects one.

Back to top