The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on Fusion.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

Network Transform Jittery Movement

digicamlux
2022-03-26 10:53:30

Hello,

I'm checking out the Sample: Fusion Application Loop.

I've found out that the character movement is jittery and looks weird:

After some tests, I found out that when I change the settings of the Interpolation Data Source in the Network Transform component to "No interpolation", the issues are fixed.

Normally, the sample is built according to Fusion documentation recommendations.

Can anybody explain what is the reason for this jittery movement?

Kind regards,

Comments

Isaac_Augusto
2022-03-31 18:30:23

Hi,

This jittering is caused by the current camera tracking logic, it's running on Render() instead of LateUpdate(), a fix is already on it's way. So, there's nothing wrong with the movement, input or any Fusion related logic.

--

Isaac Augusto

Photon Fusion Team

ueharajohji
2022-09-21 06:23:19

@Isaac_Augusto Hello, I am experiencing the same thing. I have the latest fusion but still Interpolation data source "Auto" causes jittery movement.

Mine is like this

Interpolation data source : Auto (jump and movement is a little bit jittery.)

Interpolation data source : No Interpolation (the jump and overall movement is smooth)

ueharajohji
2022-09-21 08:39:23

I fixed the jitteriness by removing the collider in the Interp. data source.

MHG_Developer
2022-12-03 01:34:08

I am coming from PUN 1 & 2, so trying to learn Fusion has been challenging due to making wrong assumptions about the host and client network behaviors. Still a little sketchy on some of the functions but have made progress.

I've been using both App Loop and Tanknarok as examples. My setup for tank rotations is a little more complex using a camera and reticle similar to Rocket League. I created it in single player with no network first then added Fusion 1.1.3. and began trying to mimic Tanknoarok. Seemed simple at first but it took me a little over a month, three different attempts to get my version working properly. Took 2 weeks just to figure out how the input() worked for Host/Client mostly because I had vars that were not being calculated correctly for multiplayer - host and client were fighting the settings (I think). Anyway, I figured it all out and also noticed a jitter on the Client only. Host was smooth as glass. So I got nervous that I was going to spend another two weeks trying to figure out why the jitter. Thankfully a search revealed this thread and I decided to try @ueharajohji settings. It worked! Thank You!!!

Seems counter intuitive but at this point I don't care.

Back to top