Marco Polo suddenly fails??

I'm unable to get a room with a brand-new default Photon install (after entering application id). It silently fails. However, DemoWorker is still able to create a room. I checked out the difference.
PhotonNetwork.CreateRoom(this.roomName, true, true, 10);
vs.
PhotonNetwork.CreateRoom(null, true, true, 4);
So to sanity check, I swap this.roomName for null, to see if it fails too.
It does not... the only difference is 4 instead of 10, but that can't be it. (because I checked that too.)
What gives? How did Marco Polo break overnight?

I've started over with a completely minimal set of code:
using UnityEngine;
using System.Collections;

public class Connect : Photon.MonoBehaviour {

	// Use this for initialization
	void Start() 
    {
        Debug.Log("Connecting to Photon cloud...");
        PhotonNetwork.ConnectUsingSettings("dev");
	}
    void OnJoinedLobby()
    {
        Debug.Log("I got in the lobby! Looking for a room...");
        PhotonNetwork.JoinRandomRoom();
    }
    void OnPhotonRandomJoinFailed()
    {
        Debug.Log("No rooms available. Making a new one...");
        PhotonNetwork.CreateRoom("");
    }

    void OnJoinedRoom()
    {
        Debug.Log("something worked for a change.");
    }
}

OnJoinedRoom is never called; and I've not the foggiest idea why.

Comments

  • I've got it.
    joinrandom failed, client stays on masterserver: OperationResponse 225: ReturnCode: 32760 (No match found). Parameters: {}.
    
    This was the culprit; or rather "error pause" being toggled on in the Console on account of a brand-new Unity install. Boy is my face red. :oops: I'd grown so used-to seeing that error in working code that I'd never realized that it stops execution by default.

    ....well that was a day of programming well spent. :lol:
Sign In or Register to comment.