Non-local Server

Hi, I hava a problem.

I used de viking stuff to test the networking things.
When I set the IP's to local everything works fine. When I use the public IP's, I get a time out BUT other people from outside the network can connect.
So I think (because the server is in the DMZ) the server send the response to himself. Does the photon server answer to an random port or is this a fix port?
So I could set up the router to send those answers to my IP.
(I found only ports client to gameserver and gameserver to masterserver)

thanks

Comments

  • Hi Dengog,

    Photon uses fixed ports - lookup the list of Listeners in the PhotonServer.config at the <Loadbalancing ...> node.

    -Philip
  • hi and thanks

    but my question was not good^^
    soooo, if i setup the gameserver with the public ip "192.168.1.106" everything works fine, i can join.
    but when i change the public ip to "dengog.dyndns.org" or "the public ip" a friend of mine can join but i can't, i receive a timeout.
    (i also changed the ip's in the script)

    Any ideas?
    Could it be, that the server can't send a response because a server in a dmz can't access the other machines in the network?

    I run a netstat on the server when i tried to connect to the server and the state was "CLOSE_WAIT".
    (My server is in a dmz so i don't need to open ports)
  • Thats no public IP.
    192.168.xxx.xxx is by definition on the IP network range schemes a private LAN IP

    To allow others from outside to join you will need to use the IP thats shown when you visit http://www.whatsmyip.com and similar pages or get a static ip from your ISP
  • yes but in the settings i must put the private lan ip in the publicip section.

    i.e.:
    <!-- Leave empty and the the IP address will be looked up dynamically at runtime. -->
    <setting name="PublicIPAddress" serializeAs="String">
    <value>192.168.1.106</value>
    </setting>

    when i put in my ip (so my public ip) other people can connect BUT i cannot connect myself form inside the network.
  • If everyone else can connect with the public IP, then at least the firewall and router settings are fine.
    But: If everyone else is able to connect to your "public" server, then it's odd you can't yourself. Are you sure others connect successfully?
  • yes i'm sure.
    a friend downloaded the project and he was able to connect to my server.
    I don't know what i can change or do, that i can connect too. :?

    Edit: i wrote the public ip into the settings.
    Now when i try to connect with the public ip nothing happens an it stucks at "Connecting...".
    When i try to connect with the local ip, it stucks at "ConnectingToGameserver".
    (it tried the marco polo tutorial)
  • If anyone can connect to your "public" server just fine, it should not be an issue locally either. I fear this is not a problem with Photon but with your setup.
    Again: make sure you only edit the "publicIP" setting of the game server config. No other changes are usually required.

    I will point a colleague here. Maybe Nicole has another idea.
  • Hi,

    I'm not sure if I understand completely what you are doing. I'd like to check your config files. Can you please send me:

    - PhotonServer.config
    - ALL *.dll.config files in your Game (or Game1,Game2) + Master application directory
    - the GSGame.log + MSMaster.log files

    (please upload it, attach to this post, per private message, or per mail to [email protected] - see here for details: viewtopic.php?f=5&t=1913)

    Also, please provide a tracert from your client machine to the public IP (the one you set in the config files), and please also try to open a telnet connection to that public IP on port 4530 + 4531. Let me know the results. With these infos, we should sort out the problem pretty fast. Thanks!
Sign In or Register to comment.