How to run Photon-Unreal-SDK_DemoParticle-UE4 ??

i first tried with unreal engine 4.25.4, then i tried the 4.12.5 ( the one suggested in the text file ), with both (on win 10 x64) it says "Unable to open this project, as it was made with a newer ( or different ) version of the Unreal Engine."

i would know which version to install to run it! please. thanx in advance!

Comments

  • Hi @Ngrav8.


    The current release of Photon-Unreal-SDK_DemoParticle-UE4 is currently by default is set to version 4.20 of Unreal Engine.

    You can switch the Unreal Engine version by right-clicking on the file 'PhotonDemoParticle.uproject' and selecting "Switch Unreal Engine version..." from the context menu. The demo project should work with any version above 4.19. So feel free to set it to 4.25 to avoid having to install another Unreal Engine version that you otherwise have no need for.


    Also please be aware that the demo project still expects the latest v4 version of the Photon Client SDKs, so either download the latest v4 client (you can find it on the download page for the SDK of your choice under "Other downloads") or follow the instructions at https://forum.photonengine.com/discussion/18903/cant-build-photondemoparticle-ue4#latest to adjust the demo to the APIs of the v5 Client SDKs.

  • Ngrav8
    Ngrav8
    edited November 26

    @Kaiserludi i was able to test successfully the demo (finally). Now i'm having problems in packaging it for windows..

    this is what happen when i try to do it.. it does nothing except opening automatically this page...

    any suggestion?

  • Hi @Ngrav8.


    That means that Unreal can't find any compatible Visual Studio version, which is required to build the project.

    Unreal 4.25 and all as of the time of this post already available newer versions of Unreal all use Visual Studio 2019, so you need to install that version.


    What's interesting is that you could build the editor. I would have thought that that was not possible without having a compatible Visual Studio installation available either. So maybe you already have is installed and used it to build the Editor, but the Unreal Editor can't find it? Maybe some Visual Studio component has not been selected during installation (you could re-install it and do a full installation of everything included to rule that out) or the environment variables (especially the PATH environment variable) is not set-up correctly (however the Visual Studio installer should normally set them up correctly).


    This is definitely not a Photon-related issue, but one with Unreal and Visual Studio in general.

  • i followed accurately the documantation about all the required components when installing visual studio.. i believed the "2022" version was good for running the project with unreal 4.25... i've also been able to launch the project for windows.. but when it comes to packaging, it only opens the "no more existent" web page..

    so your suggestion is to remove the visual studio 2022 version and install the 2019 one in order to rebuild the demo project and try to do the packages?

  • Hi @Ngrav8.


    Each Unreal version looks for a specific version of Visual Studio, which was VS 2017 up to UE 4.24 (with VS 2015 being used for really old versions) and has been changed to VS 2019 for UE 4.25 and above.


    You can have several Visual Studio versions installed in parallel without problems. So you might want to have VS 2019 and VS 2022 and potentially also other versions installed, if you need different versions for different projects. However for all versions to work correctly, you need to install them in chronological order.

    So VS 2019 needs to be installed before VS 2022, VS 2017 needs to be installed before VS 2019, and so on.

    So yes, you need to uninstall VS 2022 first, then think about which is the oldest VS version that you need, then install that version and then afterwards all other major versions that you need in their chronological order. So if i.e. you need to use VS 2017, VS 2019 and VS 2022 for different projects, then install them in that order.

  • Ngrav8
    Ngrav8
    edited 1:30AM

    ok, i removed the 2022 version of visual studio and installed the 2019, i was able to create the package for win 64 :). Then i tried to do the package for android and unfortunately opens this page..

    as for the windows sdk i placed the files from the lib folders of the android sdk in the lib/android folder of the demoparticle project and followed again the other steps ..