How to solve the audio delay when using photonserver

I am trying to use photonvoice with photonserver instead of photoncloud.

5 clients or so, there is a delay in the audio. Sometimes the delay is as long as 30 seconds.

With 4 clients, there will be no delay.

I also tried to run the demo DemoVoicePun-Scene and got the same delay.

When I try to run it on photoncloud, there is no delay.

Is there something that needs to be configured on the server side?


The following is the environment.

I have multiple exe's running on the same PC to check.

Client SDK version: Photon voice2 2.27

Server version: 5.0.12.7770

Compile using IL2CPP


I am sorry for not being able to explain well because English is not my first language.

Answers

  • Hi @koreSato,

    Thank you for choosing Photon!

    Not sure what's wrong here.

    How do you measure delays?

    Make sure the logging level (log4net.config) of the local GameServer is not high (debug etc.).

    Make sure the local server does not have plugins enabled / used (plugins.config).

    Otherwise maybe try to disable firewall?

    Maybe the different is in the hardware / environment the server is running on.

  • Thank you for your answer.

    This problem seemed to be caused by CPU usage.

    By launching multiple clients, the CPU rate had reached 100%.

    Sorry for not noticing.


    I changed the log level from the default "debug" to "warn" and saw an improvement.

    Your advice helped me a lot.

    By lowering the log level, the CPU usage of "photon.exe" went from 40% to 2%, is this expected behavior? I was surprised by the big change.