problem with macos

I have some problem when I build for MacOS with Unity2020.3.3f1: Microphone doesn't work.
When I launch the .app produced by Unity after build, I can't hear any sound from my microphone.

Here is what I saw :
Microphone is well detected in Editor and Build.
Microphone works in Editor Mode.
I tried to sign the app without better results
It works on Windows 10 in Editor and Build.
I use Photon voice to test microphone.

When I launch the build, MacOS does not prompt me the Microphone permission popup. Unity does it.
I tried to use this unity method :
Code (CSharp):
yield return Application.RequestUserAuthorization(UserAuthorization.Microphone);
if (Application.HasUserAuthorization(UserAuthorization.Microphone))
{
Debug.Log("Microphone found");
}
else
{
Debug.Log("Microphone not found");
}

The permission prompt is not displayed but I see the log "Microphone found" in build logs.
I already set the NSusage description in info.plist file and have add 2 entitlements key for audio input and microphone like in Known issue for macos already but still not work

Thanks in advance for your help.

Comments

  • anyone ?
  • Hi @wromRed,

    Please try to reproduce using our demo scenes from the package.
    Do not modify code of Photon Voice.
    Try on different machines.
    Update to latest (or try the version I sent you on the other discussion from dropbox).