One of my players can't connect and I can't figure out why

I have one player in my multiplayer game's community that was able to connect fine until up about a week ago. Since then, whenever he has tried to connect, it times out. He doesn't get any error message, and he's tried this on multiple phones on multiple different networks. He's also tried to connect to multiple different regions. He's uninstalled and reinstalled the app. He can use the internet fine in other applications, it's just this one. At this point I have no idea what it could be... he very much wants to play the game but for some reason is not able to connect. Is there any mechanism on PUN that might 'ban' someone, or any ideas?

Thank you,


  • It could be that Windows setup a firewall rule. When you open networked apps, the system will often ask you to grant access to network(s). This might have gone wrong.
    If it's the local machine, there is sadly not a lot of feedback from the network (for the app itself), so we can't report much.
    The Analyzing Disconnects page lists several things to get info on and to try.
    Hope that helps.
  • Hi @Tobias thanks for the reply. I'll look through the analyzing disconnects page. It's weird that this randomly started happening for him. He is using iOS though so it makes me think it wouldn't be a firewall issue. He's located in Poland so maybe something is wrong with Poland :)

    Also the new forum looks cool
  • I'd say Poland is alright ;)
    But yes, it could be some issue not directly caused by the devices in the house / office.
    If you didn't update PUN in a while, I would recommend an update. It is not guaranteed to help but may avoid some other problems we fixed already.

    Glad you like the new look!