Photon Voice stops working after loading scene

I'm working on a project that uses multiple VR players and a single PC player, using Photon Voice for push to talk voice chat between all of them. The VR players can all talk to each other without a problem, and in the lobby the PC player can as well, but after loading into a separate scene the instructor loses the ability to speak. The players are unaffected, and the PC player can still hear them even after losing the ability to transmit.
I've checked to make sure the voice components being used have the same settings between the VR and PC players, and using the Debug Echo option I can still hear the PC Player's voice coming back after loading the scene, but it somehow isn't being transferred to the VR players. Any help would be much appreciated, thanks.

Comments

  • Hi @PreviewLabsRobert,

    Thank you for choosing Photon!
    but after loading into a separate scene the instructor loses the ability to speak.
    Do you use PUN Integration (PhotonVoiceNetwork/PhotonVoiceView)?
    If yes, then PhotonVoiceNetwork should persist across scenes by marking it as "Don't Destroy On Load".

    Do you see anything useful in the logs?
    Maybe increase log levels?

    In PhotonVoiceNetwork custom inspector you can see some debug info at the bottom, that may help.
    Also there is a VoiceDebugScript that should be attached to the same GameObject as PhotonVoiceView, you could use it by calling CantHearYou method on the networked object of the player(s) that you can't hear and check the logs.

    Which Photon Voice version do you use?
    We always recommend to use the latest.
Sign In or Register to comment.