No audio at first connection to Photon Voice

I'm using Photon Voice with Oculus Quest, voice transmission doesn't work when connecting for the first time (Quest asks for microphone permission) - works afterwards - is this a known issue - is there a fix? Thank you!

Best Answers

  • JohnTubeJohnTube mod
    Accepted Answer
    Hi @UnityUser,

    Thank you for choosing Photon!

    I think that you need to restart recording once permission is granted.
    Or start without recording and then enable recording when permission is granted.
  • JohnTubeJohnTube mod
    edited March 3 Accepted Answer
    Hi @UnityUser,

    call recorder.RestartRecording(true) if you choose to restart once permission is granted.

Answers

  • JohnTubeJohnTube mod
    Accepted Answer
    Hi @UnityUser,

    Thank you for choosing Photon!

    I think that you need to restart recording once permission is granted.
    Or start without recording and then enable recording when permission is granted.
  • Thank you @JohnTube - should I do this with bool force true or false?

    public void RestartRecording(bool force = false)
    {
    if (!force && !this.RequiresRestart)
    {
    if (this.Logger.IsWarningEnabled)
    {
    this.Logger.LogWarning("Recorder does not require restart.");
    }
    return;
    }
    if (this.Logger.IsDebugEnabled)
    {
    this.Logger.LogDebug("Restarting recording, RequiresRestart?={0} forcedRestart?={1}", this.RequiresRestart, force);
    }
    this.StopRecording();
    this.StartRecording();
    }
  • JohnTubeJohnTube mod
    edited March 3 Accepted Answer
    Hi @UnityUser,

    call recorder.RestartRecording(true) if you choose to restart once permission is granted.
  • There are useful scripts shared on the forum, like this and this
  • @JohnTube thanks again - fixed it
Sign In or Register to comment.