Photon voice not working in oculus quest 1.

unity3d version: 2018.4.2f1
photon voice 2 version: 2.22.3

In Oculus Quest 1, microphone is not found when using photon voice and when joined in a Oculus Party even after suppressing the Oculus System VoIP by Voip.SetSystemVoipSuppressed(true))

But it does work in Quest 2 and Rift

We could send you the source code if needed.

Answers

  • Hi @jongchan,

    Thank you for choosing Photon!
    In Oculus Quest 1, microphone is not found when using photon voice
    What error do you see?
    What microphone type did you try from Recorder? Unity or Photon?
  • Hi @jongchan,

    Try Photon microphone type as the log is for Unity microphone type.
    Having an empty device name '' in Unity is OK.
    As an additional info., it looks like the same issue is also happening in VRChat.
    Make sure permissions are granted.
    Make sure the microphone works somehow and the hardware is not broken.
  • I have tried with microphone type as photon but the mic still doesn't work while in Oculus Party.

    I don't think it's a permission issue since the mic does work when not in a Party, nor the hardware device issue since I tested with multiple Quest devices.
  • JohnTubeJohnTube mod
    edited February 19
    I see, Oculus Party is Oculus' VoIP solution / session.
    So I think you can't use Photon Voice and Oculus Party at the same time since you will be trying to access the same microphone device from two different things/places.
    So this is not supported.
    Unless you mute yourself somehow in the Oculus Party AND Oculus does not use your microphone there you could try using Photon Voice then.
    But I would say you need to use one or the other and not both at the same time.
Sign In or Register to comment.